VPN(PPTPD)一键安装包,支持Centos6和Centos7.同时支持Openvz和KVM



本安装VPN(PPTPD)安装包真正支持Centos全系列,包括Centos5,Centos6和Centos7.也不管是openvz还是kvm。

之前装pptpd非常的痛苦,openvz和kvm的方法不同,centos6和centos7的又不同。所以这次把他们整合起来了。

特别注意:

  1. centos7会自动停用默认的防火墙,安装iptables。所以如果有特别需求的同学就别碰了
  2. 装vpn的时候会自动添加 epel的yum源,有洁癖或者特殊需求的请注意
  3. 装vpn的时候会自动卸载原来装过的ppp和pptpd,所以即使想重装也无需自己手动卸载
  4. 有出现安装不了的,无法正常使用的请留言,我尽力解决下。

安装命令:

vpn

选择1:安装vpn

选择2:添加vpn账号(安装完后,随时可以使用 bash vpn_centos_pptpd.sh来选择2添加vpn账号。当然也可以直接编辑 /etc/ppp/chap-secrets

Add a Comment